Vulnerability · Published Sep 23, 2026 · Assigned by apache

CVE-2026-86246Apache Tomcat Native: Insecure OpenSSL options enabled

Critical 9.1

In plain English

A critical-severity security flaw in Apache Tomcat Native from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.3%top 71.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Initialization of a resource with an insecure default vulnerability in Apache Tomcat Native enabled insecure options by default including ALLOW_CLIENT_RENEGOTIATION, NO_EXTENDED_MASTER_SECRET, IGNORE_UNEXPECTED_EOF and ALLOW_NO_DHE_KEX. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24tomcat-native2.0.16-r0ALPINE-CVE-2026-86246
Debian:12tomcat-nativeno fix listedDEBIAN-CVE-2026-86246
Debian:13tomcat-nativeno fix listedDEBIAN-CVE-2026-86246
Debian:14tomcat-native2.0.16-1DEBIAN-CVE-2026-86246
Ubuntu:22.04:LTStomcat-nativeno fix listedUBUNTU-CVE-2026-86246
Ubuntu:24.04:LTStomcat-nativeno fix listedUBUNTU-CVE-2026-86246
Ubuntu:26.04:LTStomcat-nativeno fix listedUBUNTU-CVE-2026-86246
Ubuntu:26.10tomcat-nativeno fix listedUBUNTU-CVE-2026-86246

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat Native 2.0.0 – through 2.0.151.3.0 – through 1.3.8

Weakness: CWE-1188 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References