Vulnerability · Published Sep 23, 2026 · Assigned by apache

CVE-2026-86243Apache Tomcat Native: DoS via TLS handshake

High 7.5

In plain English

A high-severity security flaw in Apache Tomcat Native from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 52.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24tomcat-native2.0.16-r0ALPINE-CVE-2026-86243
Debian:12tomcat-nativeno fix listedDEBIAN-CVE-2026-86243
Debian:13tomcat-nativeno fix listedDEBIAN-CVE-2026-86243
Debian:14tomcat-native2.0.16-1DEBIAN-CVE-2026-86243
Ubuntu:22.04:LTStomcat-nativeno fix listedUBUNTU-CVE-2026-86243
Ubuntu:24.04:LTStomcat-nativeno fix listedUBUNTU-CVE-2026-86243
Ubuntu:26.04:LTStomcat-nativeno fix listedUBUNTU-CVE-2026-86243
Ubuntu:26.10tomcat-nativeno fix listedUBUNTU-CVE-2026-86243

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat Native 2.0.0 – through 2.0.151.3.0 – through 1.3.8

Weakness: CWE-126 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References