Vulnerability · Published Sep 17, 2026 · Assigned by GitHub_M

CVE-2026-85999Soup Sieve: Polynomial-time ReDoS (O(n²)) in the whitespace/comment trimming regex `RE_WS_END` (triggers on VALID selectors)

Medium 5.3

In plain English

A medium-severity uncontrolled resource consumption in soupsieve from facelessuser. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.6%top 50.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.9, selector_iter in src/soupsieve/css_parser.py trims the raw selector with RE_WS_END, an end-anchored WSC whitespace-and-comment expression used with search(), so the regular expression engine retries a greedy scan at every starting offset. An attacker-controlled valid selector containing a long internal whitespace run, or a selector containing a long CSS comment run followed by another token, causes quadratic CPU work before tokenization. User-controlled selectors can reach the path through soupsieve.compile() and BeautifulSoup.select(), while applications using only hard-coded selectors are unaffected. This root cause is separate from the IDENTIFIER and VALUE backtracking vulnerability because the cost occurs in RE_WS_END.search during trimming rather than token matching. The resulting CPU consumption can hold the Python GIL, exhaust workers, and stall a service without causing memory corruption or code execution. The issue is fixed in version 2.9.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12soupsieveno fix listedDEBIAN-CVE-2026-85999
Debian:13soupsieveno fix listedDEBIAN-CVE-2026-85999
Debian:14soupsieveno fix listedDEBIAN-CVE-2026-85999
PyPIsoupsieve2.9.0GHSA-j934-xhv5-fg8f
PyPIsoupsieve2.9.0PYSEC-2026-4171
Ubuntu:22.04:LTSsoupsieveno fix listedUBUNTU-CVE-2026-85999
Ubuntu:24.04:LTSsoupsieveno fix listedUBUNTU-CVE-2026-85999
Ubuntu:26.04:LTSsoupsieveno fix listedUBUNTU-CVE-2026-85999
Ubuntu:26.10soupsieveno fix listedUBUNTU-CVE-2026-85999

Affected products (as reported)

VendorProductVersions
facelessuser soupsieve < 2.9

Weakness: CWE-400, CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References