Vulnerability · Published Sep 22, 2026 · Assigned by GitHub_M
CVE-2026-85995Notepad++: Authenticode verification bypass allows modified updater execution
High 7.3
In plain English
A high-severity security flaw in notepad-plus-plus from notepad-plus-plus. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities).
Official description
Notepad++ is a free and open-source source code editor. From 8.9.7 until 8.9.8, the Notepad++ updater and signature verification path can accept a modified GUP.exe file whose embedded certificate metadata remains present even though its Authenticode digest is invalid. An attacker who can replace or plant the updater-related file can cause Notepad++ to launch attacker-modified code when a user triggers the updater path, but the issue does not provide remote code execution by itself. This issue is fixed in version 8.9.8.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| notepad-plus-plus | notepad-plus-plus | < 8.9.8 |
Weakness: CWE-347 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/notepad-plus-plus/notepad-plus-plus/security/advisories/GHSA-cx87-7hhq-m2j3 x_refsource_CONFIRM
- https://github.com/notepad-plus-plus/notepad-plus-plus/commit/9edf40f725ce62b26c454905e39f0f7fdbbb3ffa x_refsource_MISC
- https://github.com/notepad-plus-plus/notepad-plus-plus/releases/tag/v8.9.8 x_refsource_MISC
- https://notepad-plus-plus.org/news/v898-released x_refsource_MISC