Vulnerability · Published Sep 11, 2026 · Assigned by Perforce
CVE-2026-85979Command Injection in Puppet Enterprise
High 8.6
In plain English
A high-severity OS command injection in Puppet Enterprise from Perforce Software. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities).
Official description
Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system. It affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2. This has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:24.04:LTS | puppetserver | no fix listed | UBUNTU-CVE-2026-85979 |
| Ubuntu:26.04:LTS | puppetserver | no fix listed | UBUNTU-CVE-2026-85979 |
| Ubuntu:26.10 | puppetserver | no fix listed | UBUNTU-CVE-2026-85979 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Perforce Software | Puppet Enterprise | 2023.8.0 – through 2023.8.102025.0.0 – through 2025.11.2 |
Weakness: CWE-78, CWE-20, CWE-269 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N