Vulnerability · Published Sep 4, 2026 · Assigned by AMZN
CVE-2026-85787An incomplete list of disallowed inputs in the SQL validation component of Amazon awslabs postgres-mcp-server
Medium 6.5
In plain English
A medium-severity security flaw in postgres-mcp-server from Amazon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities).
Official description
An incomplete list of disallowed inputs in the SQL validation component in Amazon awslabs postgres-mcp-server before version 1.1.7 might allow an unauthenticated actor to modify data beyond the read-only scope by placing crafted SQL into the content that is submitted when an authenticated user interacts with the MCP server. To remediate this issue, users should upgrade to version 1.1.7 or above.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Amazon | postgres-mcp-server | 0 – before 1.1.7 |
Weakness: CWE-184 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
References
- https://pypi.org/project/awslabs.postgres-mcp-server/1.1.7/ patch, release-notes
- https://aws.amazon.com/security/security-bulletins/2026-101-aws/ vendor-advisory