Vulnerability · Published Sep 4, 2026 · Assigned by VulnCheck
CVE-2026-85600Grav Admin before 2.0.21 Stored XSS via username
Medium 5.4
In plain English
A medium-severity cross-site scripting in grav-plugin-admin2 from getgrav. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities).
Official description
Grav Admin (getgrav/grav-plugin-admin2) versions <= 2.0.19 contain a stored cross-site scripting vulnerability in the tHtml() function (src/lib/stores/i18n.svelte.ts), which substitutes untrusted parameters such as usernames into translation templates before parsing the result as markdown. Grav's server-side username validation (DataUser::isValidUsername) blocks filesystem-dangerous characters but not <, >, ", or ', allowing an attacker to register a username containing an HTML payload. When an administrator views a UI surface that renders the username through tHtml()—such as the two-factor force-disable confirmation prompt or the 'page is locked' editor notice—the payload executes in their authenticated session. Fixed in 2.0.21.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| getgrav | grav-plugin-admin2 | 0 – through 2.0.19 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
References
- GitHub Security Advisory (GHSA-96xm-c5hr-59rx) vendor-advisory
- VulnCheck Advisory: Grav Admin before 2.0.21 Stored XSS via username third-party-advisory