Vulnerability · Published Oct 2, 2026 · Assigned by apache

CVE-2026-85086Apache Thrift: Perl TLS client disables certificate verification by default

Medium 6.9

In plain English

A medium-severity improper certificate validation in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities).

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.2%top 92.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper certificate validation, Initialization of a resource with an insecure default vulnerability in Apache Thrift perl bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12thriftno fix listedDEBIAN-CVE-2026-85086
Debian:13thriftno fix listedDEBIAN-CVE-2026-85086
Debian:14thriftno fix listedDEBIAN-CVE-2026-85086
Ubuntu:22.04:LTSthriftno fix listedUBUNTU-CVE-2026-85086
Ubuntu:24.04:LTSthriftno fix listedUBUNTU-CVE-2026-85086
Ubuntu:26.04:LTSthriftno fix listedUBUNTU-CVE-2026-85086
Ubuntu:26.10thriftno fix listedUBUNTU-CVE-2026-85086

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Thrift 0 – before 0.25.0

Weakness: CWE-295, CWE-1188 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U

References