Vulnerability · Published Sep 4, 2026 · Assigned by openjs
CVE-2026-85024undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression
Medium 5.9
In plain English
A medium-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici bundles a WebSocket client whose permessage-deflate size-limit cleanup removes all listeners from the internal zlib inflate stream, including its error listener, while that stream can still emit. When a remote peer sends a compressed payload that crosses the built-in 128 MiB decompressed-payload limit and then contains a malformed DEFLATE byte, the inflate stream emits a data error with no listener attached, which Node.js treats as a fatal unhandled error and terminates the entire process. Exploitation is remote and unauthenticated, requires no application mistake, and is asymmetric, since roughly 130 KB on the wire expands past the limit and crashes the process, and reconnecting can repeat the crash. This affects undici versions from 6.25.0 up to 6.28.1, from 7.28.0 up to 7.29.1, and from 8.1.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-85024 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-85024 |
| Debian:14 | node-undici | 8.10.2+dfsg+~cs3.2.2-1 | DEBIAN-CVE-2026-85024 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-85024 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-85024 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-85024 |
| npm | undici | 7.29.1 | GHSA-3wwx-pv8p-q78v |
| npm | undici | 8.10.2 | GHSA-3wwx-pv8p-q78v |
| npm | undici | 6.28.1 | GHSA-3wwx-pv8p-q78v |
Affected products (as reported)
Weakness: CWE-248 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H