Vulnerability · Published Sep 4, 2026 · Assigned by openjs
CVE-2026-84961undici vulnerable to TLS certificate validation bypass via dropped connect options in BalancedPool
High 7.4
In plain English
A high-severity improper certificate validation in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici's BalancedPool constructor passes its entire options object through an internal deep-clone that serializes and reparses the value as JSON. Because JSON cannot represent functions, any function-valued TLS option, such as a caller-supplied checkServerIdentity callback or a custom connector inside the connect option, is silently discarded before it reaches the TLS layer. As a result a peer whose certificate the application's custom checkServerIdentity was written to reject, but which still passes Node's default hostname and chain checks, is accepted when reached through BalancedPool. The Client, Pool, and Agent dispatchers are not affected because they extract the connect and tls options before cloning. This affects undici versions from 7.24.1 up to 7.29.1 and from 8.0.0 up to 8.10.2, and only when the application supplies a function-valued connect or tls option to BalancedPool. Users should upgrade to undici 7.29.1 or 8.10.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | nodejs | 1:24.21.0-1.module_el8.10.0+4292+21afb960 | ALSA-2026:74085 |
| AlmaLinux:9 | nodejs | 1:24.21.0-1.module_el9.8.0+321+1555b6a2 | ALSA-2026:73838 |
| AlmaLinux:8 | nodejs-devel | 1:24.21.0-1.module_el8.10.0+4292+21afb960 | ALSA-2026:74085 |
| AlmaLinux:9 | nodejs-devel | 1:24.21.0-1.module_el9.8.0+321+1555b6a2 | ALSA-2026:73838 |
| AlmaLinux:8 | nodejs-docs | 1:24.21.0-1.module_el8.10.0+4292+21afb960 | ALSA-2026:74085 |
| AlmaLinux:9 | nodejs-docs | 1:24.21.0-1.module_el9.8.0+321+1555b6a2 | ALSA-2026:73838 |
| AlmaLinux:8 | nodejs-full-i18n | 1:24.21.0-1.module_el8.10.0+4292+21afb960 | ALSA-2026:74085 |
| AlmaLinux:9 | nodejs-full-i18n | 1:24.21.0-1.module_el9.8.0+321+1555b6a2 | ALSA-2026:73838 |
| AlmaLinux:8 | nodejs-libs | 1:24.21.0-1.module_el8.10.0+4292+21afb960 | ALSA-2026:74085 |
| AlmaLinux:9 | nodejs-libs | 1:24.21.0-1.module_el9.8.0+321+1555b6a2 | ALSA-2026:73838 |
| AlmaLinux:8 | nodejs-nodemon | 3.1.14-2.module_el8.10.0+4250+09238ed4 | ALSA-2026:74085 |
| AlmaLinux:9 | nodejs-nodemon | 3.1.14-3.module_el9.8.0+292+f4eaf8b2 | ALSA-2026:73838 |
| AlmaLinux:8 | nodejs-packaging | 2021.06-6.module_el8.10.0+4086+70facd4a | ALSA-2026:74085 |
| AlmaLinux:9 | nodejs-packaging | 2021.06-6.module_el9.7.0+209+ecf6523e | ALSA-2026:73838 |
| AlmaLinux:8 | nodejs-packaging-bundler | 2021.06-6.module_el8.10.0+4086+70facd4a | ALSA-2026:74085 |
| AlmaLinux:9 | nodejs-packaging-bundler | 2021.06-6.module_el9.7.0+209+ecf6523e | ALSA-2026:73838 |
| AlmaLinux:10 | nodejs24 | 1:24.21.0-1.el10_2 | ALSA-2026:73428 |
| AlmaLinux:10 | nodejs24-devel | 1:24.21.0-1.el10_2 | ALSA-2026:73428 |
| AlmaLinux:10 | nodejs24-docs | 1:24.21.0-1.el10_2 | ALSA-2026:73428 |
| AlmaLinux:10 | nodejs24-full-i18n | 1:24.21.0-1.el10_2 | ALSA-2026:73428 |
| AlmaLinux:10 | nodejs24-libs | 1:24.21.0-1.el10_2 | ALSA-2026:73428 |
| AlmaLinux:10 | nodejs24-npm | 2:11.19.0-1.24.21.0.1.el10_2 | ALSA-2026:73428 |
| AlmaLinux:8 | npm | 1:11.19.0-1.24.21.0.1.module_el8.10.0+4292+21afb960 | ALSA-2026:74085 |
| AlmaLinux:9 | npm | 1:11.19.0-1.24.21.0.1.module_el9.8.0+321+1555b6a2 | ALSA-2026:73838 |
| AlmaLinux:8 | v8-13.6-devel | 3:13.6.233.17-1.24.21.0.1.module_el8.10.0+4292+21afb960 | ALSA-2026:74085 |
| AlmaLinux:9 | v8-13.6-devel | 3:13.6.233.17-1.24.21.0.1.module_el9.8.0+321+1555b6a2 | ALSA-2026:73838 |
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-84961 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-84961 |
| Debian:14 | node-undici | 8.10.2+dfsg+~cs3.2.2-1 | DEBIAN-CVE-2026-84961 |
| Rocky Linux:8 | nodejs-nodemon | 0:3.1.14-2.module+el8.10.0+40277+b1b3f89e | RLSA-2026:74085 |
| Rocky Linux:8 | nodejs-nodemon | 0:3.1.14-2.module+el8.10.0+40278+50b003a3 | RLSA-2026:74085 |
| Rocky Linux:9 | nodejs-nodemon | 0:3.1.14-3.module+el9.8.0+40281+14cc6568 | RLSA-2026:73838 |
| Rocky Linux:8 | nodejs-packaging | 0:2021.06-6.module+el8.10.0+40171+8fa9c325 | RLSA-2026:74085 |
| Rocky Linux:8 | nodejs-packaging | 0:2021.06-6.module+el8.10.0+40172+38f6fdd1 | RLSA-2026:74085 |
| Rocky Linux:8 | nodejs-packaging | 0:2021.06-6.module+el8.10.0+40048+6d99f608 | RLSA-2026:74085 |
| Rocky Linux:9 | nodejs-packaging | 0:2021.06-6.module+el9.7.0+40165+d075e3f2 | RLSA-2026:73838 |
| Rocky Linux:9 | nodejs-packaging | 0:2021.06-6.module+el9.7.0+40052+e32ea525 | RLSA-2026:73838 |
| Rocky Linux:9 | nodejs-packaging | 0:2021.06-6.module+el9.8.0+40164+8921ab53 | RLSA-2026:73838 |
| Rocky Linux:9 | nodejs-packaging | 0:2021.06-6.module+el9.7.0+40153+4d595597 | RLSA-2026:73838 |
| Rocky Linux:10 | nodejs24 | 1:24.21.0-1.el10_2 | RLSA-2026:73428 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-84961 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-84961 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-84961 |
| npm | undici | 7.29.1 | GHSA-w293-vg96-wgc3 |
| npm | undici | 8.10.2 | GHSA-w293-vg96-wgc3 |
Affected products (as reported)
Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N