Vulnerability · Published Sep 4, 2026 · Assigned by openjs

CVE-2026-84947undici vulnerable to response truncation via oversized chunked responses in the dump interceptor

Low 3.7

In plain English

A low-severity improper input validation in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.2%top 90.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

undici's dump interceptor reads and discards a response body up to a configurable maximum size. When a response declares a Content-Length that exceeds the maximum, the interceptor aborts cleanly, but when a response has no Content-Length and is chunked, the interceptor instead signals completion early once the accumulated size reaches the maximum, without pausing or aborting the request. Because the underlying parser keeps delivering body bytes, a second completion signal fires and trips an internal assertion, which aborts the request and tears down the connection. The application is left observing a misleading successful status with an empty or truncated body while the connection has actually been disconnected. This affects undici versions from 7.1.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-undicino fix listedDEBIAN-CVE-2026-84947
Debian:13node-undicino fix listedDEBIAN-CVE-2026-84947
Debian:14node-undici8.10.2+dfsg+~cs3.2.2-1DEBIAN-CVE-2026-84947
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-84947
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-84947
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2026-84947
npmundici8.10.2GHSA-2gqq-gqf2-x968
npmundici7.29.1GHSA-2gqq-gqf2-x968

Affected products (as reported)

VendorProductVersions
undici undici 7.1.0 – before 7.29.18.0.0 – before 8.10.2

Weakness: CWE-20, CWE-248 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

References