Vulnerability · Published Sep 4, 2026 · Assigned by openjs
CVE-2026-84890undici vulnerable to Denial of Service via unbounded decompression of compressed responses
Medium 5.9
In plain English
A medium-severity resource allocation without limits in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-84890 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-84890 |
| Debian:14 | node-undici | 8.10.2+dfsg+~cs3.2.2-1 | DEBIAN-CVE-2026-84890 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-84890 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-84890 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-84890 |
| npm | undici | 8.10.2 | GHSA-3xpg-4rpp-hhhm |
| npm | undici | 7.29.1 | GHSA-3xpg-4rpp-hhhm |
Affected products (as reported)
Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H