Vulnerability · Published Sep 16, 2026 · Assigned by apache

CVE-2026-84439Apache ZooKeeper: Audit log injection via unsanitized output from multiple sources

Medium 5.3

In plain English

A medium-severity security flaw in Apache ZooKeeper from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.7%top 45.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

When audit logging is enabled (zookeeper.audit.enable=true), an unauthenticated attacker can inject arbitrary fields into Apache ZooKeeper's audit log by sending a digest authentication request with tab characters (\t) embedded in the username. Because the audit log uses tab-separated key=value format, the injected tabs are parsed as legitimate field separators, allowing the attacker to spoof audit results (e.g., injecting result=success), forge operation types, and corrupt forensic evidence. A log injection vulnerability in Apache ZooKeeper allows a client that can call setACL to inject forged key-value fields into zookeeper_audit.log. When audit logging is enabled, the server serializes attacker-controlled digest ACL ids into the acl= audit field without escaping tab characters. Because audit events are emitted as tab-separated key=value records, a crafted ACL id can make one successful setAcl event appear to contain forged fields such as operation=delete and znode=/forged. This undermines the integrity of downstream audit parsing, alerting, and incident response. This issue affects Apache ZooKeeper: from 3.9.0 through 3.9.5, from 3.8.0 through 3.8.6. Users are recommended to upgrade to version 3.9.6 or 3.8.7, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zookeeperno fix listedDEBIAN-CVE-2026-84439
Debian:13zookeeperno fix listedDEBIAN-CVE-2026-84439
Debian:14zookeeper3.9.6-1DEBIAN-CVE-2026-84439
Ubuntu:22.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-84439
Ubuntu:24.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-84439
Ubuntu:26.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-84439
Ubuntu:26.10zookeeperno fix listedUBUNTU-CVE-2026-84439

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ZooKeeper 3.9.0 – through 3.9.53.8.0 – through 3.8.6

Weakness: CWE-117 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References