Vulnerability · Published Sep 2, 2026 · Assigned by openjs

CVE-2026-84394fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

High 7.5

In plain English

A high-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 67.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri accepts a host that contains an unbalanced or misplaced authority bracket without reporting an error. A host that starts with an opening bracket but does not end with a closing bracket is neither validated as an IP literal nor canonicalized as a domain name, so parse() returns it as the host with error undefined, while Node's URL and the HTTP clients built on it resolve the same string to a different host. An application that reads the parsed host to make a host decision, such as an SSRF denylist, a redirect allowlist, or proxy routing, and then passes the original URL to an HTTP client evaluates its policy against a string that is not the host the request reaches. The same host is carried through normalize, equal, and resolve. This affects fast-uri versions 2.4.5, 3.1.6, and 4.1.3, and is fixed in 2.4.6, 3.1.7, and 4.1.4, where parse() reports a malformed host for any host that contains a bracket but is not a valid IPv6 literal.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-84394
Debian:14node-ajv8.20.0~ds+~cs7.1.5-1DEBIAN-CVE-2026-84394
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-84394
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-84394
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-84394
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-84394
npmfast-uri2.4.6GHSA-58mr-gqgx-xq4g
npmfast-uri3.1.7GHSA-58mr-gqgx-xq4g
npmfast-uri4.1.4GHSA-58mr-gqgx-xq4g

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 2.4.5 – before 2.4.63.1.6 – before 3.1.74.1.3 – before 4.1.4

Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References