Vulnerability · Published Oct 12, 2026 · Assigned by GitHub_M

CVE-2026-84360Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools

High 8.1

In plain English

A high-severity authentication bypass in nginx-ui from 0xJacky. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 63.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/0xJacky/Nginx-UI1.9.10-0.20260703131214-23d1934099b0GHSA-vc32-4gwf-77xp
Gogithub.com/0xJacky/Nginx-UI1.9.10-0.20260703131214-23d1934099b0GO-2026-6799

Affected products (as reported)

VendorProductVersions
0xJacky nginx-ui < 2.4.1

Weakness: CWE-288 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

References