Vulnerability · Published Oct 12, 2026 · Assigned by GitHub_M

CVE-2026-84314Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint

High 8.7

In plain English

A high-severity missing authorization in nginx-ui from 0xJacky. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.4%top 63.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/0xJacky/Nginx-UI1.9.10-0.20260703131214-23d1934099b0GHSA-2gc7-j998-5xx6
Gogithub.com/0xJacky/Nginx-UI1.9.10-0.20260703131214-23d1934099b0GO-2026-6771

Affected products (as reported)

VendorProductVersions
0xJacky nginx-ui < 2.4.1

Weakness: CWE-285, CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References