Vulnerability · Published Sep 1, 2026 · Assigned by GitHub_M

CVE-2026-84307Filament: Password validity disclosure for accounts denied panel access on login page

Low 3.7

In plain English

A low-severity security flaw in filament from filamentphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.5%top 60.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Filament is a collection of full-stack components for accelerated Laravel development. From 4.0.0 until 4.12.5 and 5.7.5, packages/panels/src/Auth/Pages/Login.php presents the multi-factor authentication challenge before evaluating canAccessPanel(). For an account that canAccessPanel() denies, submitting the correct password renders the MFA challenge while an incorrect password returns the generic authentication failure, allowing an unauthenticated attacker to confirm whether a candidate password is valid for that account. When email-based MFA is configured, the correct-password path also sends a login code to the account holder. The issue applies only to accounts that have MFA enabled and are denied panel access. Authentication is not bypassed because canAccessPanel() still runs after the challenge, and no session is created. This issue is fixed in versions 4.12.5 and 5.7.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistfilament/filament4.12.5GHSA-xwpv-pqxp-5v36
Packagistfilament/filament5.7.5GHSA-xwpv-pqxp-5v36

Affected products (as reported)

VendorProductVersions
filamentphp filament >= 4.0.0, < 4.12.5>= 5.0.0, < 5.7.5

Weakness: CWE-204 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

References