Vulnerability · Published Sep 1, 2026 · Assigned by GitHub_M

CVE-2026-84306Filament: Multi-factor authentication (app) codes can still be used after a newer code has been used

Medium 6.5

In plain English

A medium-severity security flaw in filament from filamentphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 60.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Filament is a collection of full-stack components for accelerated Laravel development. From 4.0.0 until 4.12.6 and 5.7.6, packages/panels/src/Auth/MultiFactor/App/AppAuthentication.php uses AppAuthentication::verifyCode() with a used-code cache key derived from both the app authentication secret and the submitted TOTP code. This isolates the newest accepted timestep by code instead of by secret, allowing a previously issued app-based MFA code to be accepted after a newer code has already been used. Reuse of the exact same code was already prevented, but another code inside the accepted time window remained usable. An attacker who obtains the target account's password and one app-based MFA code can use that code for the remainder of the configured window, which is approximately four minutes with the default settings, even after the legitimate account holder logs in with a newer code. Email-based MFA is not affected. This issue is fixed in versions 4.12.6 and 5.7.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistfilament/filament4.12.6GHSA-r3j6-gpjw-qfjr
Packagistfilament/filament5.7.6GHSA-r3j6-gpjw-qfjr

Affected products (as reported)

VendorProductVersions
filamentphp filament >= 4.0.0, < 4.12.6>= 5.0.0, < 5.7.6

Weakness: CWE-294 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N

References