Vulnerability · Published Sep 2, 2026 · Assigned by openjs

CVE-2026-84292fast-uri vulnerable to authority injection via an unvalidated port in serialize

High 7.5

In plain English

A high-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.2%top 84.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri serializes the port component of a URI without validating it. When recomposing the authority, the userinfo and host components are escaped but the port is concatenated verbatim, so a port value that is not a sequence of digits can inject authority delimiters, demoting the intended host to userinfo and pointing the authority at an attacker-controlled host. Both fast-uri and Node's URL read the result back as the attacker's host with no error, so re-validating the built URI does not catch it. This affects applications that build URIs from parts and assign untrusted data to the port component through the serialize, normalize, or equal functions in their object forms. The issue affects fast-uri versions before 2.4.6, from 3.0.0 before 3.1.7, and from 4.0.0 before 4.1.4. It is fixed in 2.4.6, 3.1.7, and 4.1.4, where recomposeAuthority rejects any port that is not a digit sequence per RFC 3986.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10cockpit-image-builder94.4-1.el10_2ALSA-2026:71543
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-84292
Debian:14node-ajv8.20.0~ds+~cs7.1.5-1DEBIAN-CVE-2026-84292
Rocky Linux:10cockpit-image-builder0:94.4-1.el10_2RLSA-2026:71543
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-84292
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-84292
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-84292
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-84292
npmfast-uri2.4.6GHSA-qw65-cvwx-89v3
npmfast-uri3.1.7GHSA-qw65-cvwx-89v3
npmfast-uri4.1.4GHSA-qw65-cvwx-89v3

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 0 – before 2.4.63.0.0 – before 3.1.74.0.0 – before 4.1.4

Weakness: CWE-116 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References