Vulnerability · Published Sep 1, 2026 · Assigned by VulnCheck
CVE-2026-84188librenms before 26.7.0 Stored XSS via graph_descr settings
Medium 4.8
In plain English
A medium-severity cross-site scripting in librenms from librenms. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | librenms/librenms | 26.7.0 | GHSA-7cj5-v4pp-v632 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
References
- GitHub Security Advisory (GHSA-7cj5-v4pp-v632) vendor-advisory
- VulnCheck Advisory: librenms before 26.7.0 Stored XSS via graph_descr settings third-party-advisory