Vulnerability · Published Sep 1, 2026 · Assigned by HeroDevs

CVE-2026-83557jackson-databind omits java.lang.Comparable from DefaultBaseTypeLimitingValidator's unsafe base types

Medium 5.6

In plain English

A medium-severity unsafe deserialization in jackson-databind from FasterXML. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.6Medium
Exploit odds (30 days)0.7%top 46.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

DefaultBaseTypeLimitingValidator is the PolymorphicTypeValidator applied automatically whenever @JsonTypeInfo is used without an explicitly configured custom validator. It denies polymorphic resolution only for a fixed set of "unsafe base types", and its isSafeSubType method returns true unconditionally for every base type outside that set. java.lang.Comparable was absent from the list despite being implemented by a very large fraction of JDK and application classes, comparable in breadth to java.io.Serializable, which is on the list for that reason. An application declaring an @JsonTypeInfo-annotated property or class with Comparable as its base type, and no custom PolymorphicTypeValidator, will accept a type identifier for essentially any class implementing Comparable. This yields an attacker-controlled object instantiation primitive; a demonstrated case constructs a java.io.File for an arbitrary attacker-chosen path, which becomes path-traversal-adjacent if the application subsequently calls path-sensitive methods on the value. No class implementing Comparable has been identified that yields code execution through deserialization alone. Global Default Typing via activateDefaultTyping is not affected, because that method structurally requires an explicit PolymorphicTypeValidator argument. This affects com.fasterxml.jackson.core:jackson-databind from 2.11.0 before 2.18.10, from 2.19.0 before 2.21.6, and from 2.22.0 before 2.22.2, and tools.jackson.core:jackson-databind from 3.0.0 before 3.1.6 and from 3.2.0 before 3.2.2. Users should upgrade to 2.18.10, 2.21.6, 2.22.2, 3.1.6, or 3.2.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12jackson-databindno fix listedDEBIAN-CVE-2026-83557
Debian:13jackson-databindno fix listedDEBIAN-CVE-2026-83557
Debian:14jackson-databind2.18.11-1DEBIAN-CVE-2026-83557
Mavencom.fasterxml.jackson.core:jackson-databind2.18.10GHSA-gx83-3vf8-gh7j
Mavencom.fasterxml.jackson.core:jackson-databind2.21.6GHSA-gx83-3vf8-gh7j
Mavencom.fasterxml.jackson.core:jackson-databind2.22.2GHSA-gx83-3vf8-gh7j
Maventools.jackson.core:jackson-databind3.1.6GHSA-gx83-3vf8-gh7j
Maventools.jackson.core:jackson-databind3.2.2GHSA-gx83-3vf8-gh7j
Ubuntu:22.04:LTSjackson-databindno fix listedUBUNTU-CVE-2026-83557
Ubuntu:24.04:LTSjackson-databindno fix listedUBUNTU-CVE-2026-83557
Ubuntu:26.04:LTSjackson-databindno fix listedUBUNTU-CVE-2026-83557
Ubuntu:26.10jackson-databindno fix listedUBUNTU-CVE-2026-83557

Affected products (as reported)

VendorProductVersions
FasterXML jackson-databind 2.11.0 – before 2.18.102.19.0 – before 2.21.62.22.0 – before 2.22.2
FasterXML jackson-databind 3.0.0 – before 3.1.63.2.0 – before 3.2.2

Weakness: CWE-502, CWE-915 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

References