Vulnerability · Published Sep 16, 2026 · Assigned by GitHub_M

CVE-2026-82410Pocketbase: Unhandled panic in worker goroutines

High 8.7

In plain English

A high-severity security flaw in pocketbase from pocketbase. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.6%top 52.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Pocketbase is an open source web backend written in go. Prior to 0.22.48 and 0.39.7, PocketBase's panic-recovery middleware covers regular request handling but not internal child and worker goroutines. A panic in one of these internal goroutines can escape recovery and terminate the server process, causing a denial of service. The remediation introduces routine.SafeWrap to convert recovered panics into regular errors and applies it to the affected internal worker functions. This issue is fixed in versions 0.22.48 and 0.39.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/pocketbase/pocketbase0.22.48GHSA-84vh-m24q-wjjx
Gogithub.com/pocketbase/pocketbase0.39.7GHSA-84vh-m24q-wjjx
Gogithub.com/pocketbase/pocketbase0.22.48, 0.39.7GO-2026-6489

Affected products (as reported)

VendorProductVersions
pocketbase pocketbase < 0.22.48>= 0.23.0, < 0.39.7

Weakness: CWE-248 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References