Vulnerability · Published Aug 27, 2026 · Assigned by VulnCheck
CVE-2026-81719openssl_encrypt before 1.4.9 Remote Code Execution via Plugin
High 7.8
In plain English
A high-severity code injection in openssl_encrypt from jahlives. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | openssl-encrypt | 1.4.9 | PYSEC-2026-3802 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jahlives | openssl_encrypt | 0 – before 1.4.9 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- GitHub Security Advisory (GHSA-587j-4r3v-cm2c) vendor-advisory
- VulnCheck Advisory: openssl_encrypt before 1.4.9 Remote Code Execution via Plugin third-party-advisory