Vulnerability · Published Aug 27, 2026 · Assigned by VulnCheck
CVE-2026-81715openssl_encrypt before 1.4.9 Credential Exposure via Debug Output
Low 3.3
In plain English
A low-severity sensitive data in logs in openssl_encrypt from jahlives. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8 do not redact the keyserver bearer token passed as the positional argument to 'keyserver set-token' in the --debug argv dump, because sanitize_argv_for_debug fails to sanitize it. As a result the token is printed in cleartext to stderr under --debug (even without --unsafe-show-secrets), persisting the credential in logs and terminal history. Fixed in 1.4.9.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | openssl-encrypt | 1.4.9 | PYSEC-2026-3964 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jahlives | openssl_encrypt | 0 – before 1.4.9 |
Weakness: CWE-532 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
References
- GitHub Security Advisory (GHSA-jqqp-pf9j-889j) vendor-advisory
- VulnCheck Advisory: openssl_encrypt before 1.4.9 Credential Exposure via Debug Output third-party-advisory