Vulnerability · Published Aug 27, 2026 · Assigned by VulnCheck
CVE-2026-81690verify-usb before 1.4.9 Symlink Directory Traversal Code Execution
High 7.3
In plain English
A high-severity security flaw in openssl_encrypt from jahlives. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
openssl-encrypt (pip package) before 1.4.9 contains a symlink-following flaw in its verify-usb v2 added-file allowlist scan. The scan enumerated the drive with rglob(), which in CPython does not descend into symlinked directories and treats the symlink as an ordinary directory, while O_NOFOLLOW on the hash side binds only the final path component. An evil-maid attacker with physical access to the removable drive could replace a tool-tree directory with a symlink to a copy containing byte-identical files plus a planted __pycache__/*.pyc file (which CPython loads in preference to recompiling the clean .py). The planted file is never enumerated, added_files stays 0, and verify-usb reports PASSED, resulting in code execution when the victim runs the portable install. Fixed in 1.4.9 (affects both 1.4.x and 1.5.x lines).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | openssl-encrypt | 1.4.9 | PYSEC-2026-3796 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jahlives | openssl_encrypt | 0 – before 1.4.9 |
Weakness: CWE-59 · Vector: CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:H
References
- GitHub Security Advisory (GHSA-hw7h-wqf5-6crx) vendor-advisory
- VulnCheck Advisory: verify-usb before 1.4.9 Symlink Directory Traversal Code Execution third-party-advisory