Vulnerability · Published May 12, 2026 · Assigned by openjs

CVE-2026-8162multiparty vulnerable to Denial of Service via Uncaught Exception in filename* parameter parsing

High 7.5

In plain English

A high-severity security flaw in multiparty from multiparty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.3%top 74.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

multiparty@4.2.3 and lower versions are vulnerable to denial of service via uncaught exception. By sending a multipart/form-data request with a Content-Disposition header whose filename* parameter contains a malformed percent-encoding, the parser invokes decodeURI on the value without try/catch. The resulting URIError propagates as an uncaught exception and crashes the process. Impact: any service accepting multipart uploads via multiparty is affected. Workarounds: none. Upgrade to multiparty@4.3.0 or higher.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-multipartyno fix listedDEBIAN-CVE-2026-8162
Debian:13node-multipartyno fix listedDEBIAN-CVE-2026-8162
Debian:14node-multiparty4.3.0-1DEBIAN-CVE-2026-8162
Ubuntu:22.04:LTSnode-multipartyno fix listedUBUNTU-CVE-2026-8162
Ubuntu:24.04:LTSnode-multipartyno fix listedUBUNTU-CVE-2026-8162
Ubuntu:25.10node-multipartyno fix listedUBUNTU-CVE-2026-8162
Ubuntu:26.04:LTSnode-multipartyno fix listedUBUNTU-CVE-2026-8162
Ubuntu:26.10node-multipartyno fix listedUBUNTU-CVE-2026-8162
npmmultiparty4.3.0GHSA-xh3c-6gcq-g4rv

Affected products (as reported)

VendorProductVersions
multiparty multiparty 0 – through 4.2.3

Weakness: CWE-755 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References