Vulnerability · Published Sep 16, 2026 · Assigned by GitHub_M
CVE-2026-81176Svelte devalue: DoS via malformed input
Medium 5.3
In plain English
A medium-severity resource allocation without limits in devalue from sveltejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. Prior to 5.9.2, devalue.parse does not reject out-of-bounds indices that are greater than or equal to values.length in src/parse.js. A specially crafted untrusted payload can make the parser alternate between array representations, producing quadratic work as the payload grows and causing denial of service in applications that parse untrusted devalue data. This issue is fixed in version 5.9.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | devalue | 5.9.2 | GHSA-9rgm-9g3h-6x36 |
Affected products (as reported)
Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- https://github.com/sveltejs/devalue/security/advisories/GHSA-9rgm-9g3h-6x36 x_refsource_CONFIRM
- https://github.com/sveltejs/devalue/commit/8b2a4562c446d7c36d9d629778079a5fae4243e1 x_refsource_MISC
- https://github.com/sveltejs/devalue/releases/tag/v5.9.2 x_refsource_MISC