Vulnerability · Published Sep 7, 2026 · Assigned by apache

CVE-2026-78254Apache Ant: Path traversal in ftp and scp tasks allows arbitrary file write

High 7.4

In plain English

A high-severity security flaw in Apache Ant from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.5%top 55.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The ftp and scp tasks of Apache Ant can download files from a remote server. A malicious server can provide relative paths that allow it to write outside of the dedicated target directory for the download, making it possible to overwrite files of the attacker's choice using the permissions of the user running Ant in versions prior to Ant 1.10.18. In order to exploit this vulnerability, the server would either have to be malicious or be subject to a machine-in-the-middle attack. Additionally in the case of scp or the ftp task using ftps the server must pass the server identity checks performed by the tasks. For ftp tasks not using ftps a malicious server could act as a machine-in-the-middle to provide malicious files. Starting with Ant 1.10.18 both tasks will prevent writing outside of the destination directory by default. An option is available to disable this behavior in the unlikely case that the old behavior is required by existing build files. Mitigations: Users of scp and ftp (when using ftps) in any version of Ant should not bypass server identity checks. Users of ftp not using ftps should switch to ftps where possible. All users are recommended to upgrade to Apache Ant 1.10.18, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24apache-ant1.10.18-r0ALPINE-CVE-2026-78254
Debian:12antno fix listedDEBIAN-CVE-2026-78254
Debian:13antno fix listedDEBIAN-CVE-2026-78254
Debian:14ant1.10.18-1DEBIAN-CVE-2026-78254
Ubuntu:22.04:LTSantno fix listedUBUNTU-CVE-2026-78254
Ubuntu:24.04:LTSantno fix listedUBUNTU-CVE-2026-78254
Ubuntu:26.04:LTSantno fix listedUBUNTU-CVE-2026-78254
Ubuntu:26.10antno fix listedUBUNTU-CVE-2026-78254

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Ant 1.2 – before 1.10.18

Weakness: CWE-23 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

References