Vulnerability · Published Aug 24, 2026 · Assigned by GitHub_M

CVE-2026-77634CakePHP: SmtpTransport vulnerable to CRLF header injection

High 8.2

In plain English

A high-severity security flaw in cakephp from cakephp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.3%top 75.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CakePHP is a rapid development framework for PHP. Prior to versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7 on their respective release lines, custom mail headers added with Message::setHeaders() or Message::addHeaders() do not have CRLF bytes removed, allowing header injection when user-controlled data is used in message headers. This issue is fixed in versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcakephp/cakephp4.5.12GHSA-2qh5-382h-3jpc
Packagistcakephp/cakephp4.6.5GHSA-2qh5-382h-3jpc
Packagistcakephp/cakephp5.1.9GHSA-2qh5-382h-3jpc
Packagistcakephp/cakephp5.2.14GHSA-2qh5-382h-3jpc
Packagistcakephp/cakephp5.3.7GHSA-2qh5-382h-3jpc
Ubuntu:22.04:LTScakephpno fix listedUBUNTU-CVE-2026-77634

Affected products (as reported)

VendorProductVersions
cakephp cakephp >= 4.5.0, < 4.5.12>= 4.6.0, < 4.6.5>= 5.0.0, < 5.1.9>= 5.2.0, < 5.2.14>= 5.3.0, < 5.3.7

Weakness: CWE-93 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References