Vulnerability · Published Sep 16, 2026 · Assigned by GitHub_M
CVE-2026-77411RabbitMQ amqp091-go: Protocol Desynchronization and Frame Injection via Integer Overflow in readLongstr
Critical 9.5
In plain English
A critical-severity security flaw in amqp091-go from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, readLongstr in read.go returns an empty string and a nil error when a declared AMQP longstr length exceeds 0x7FFFFFFF instead of returning ErrSyntax. The function leaves the declared field bytes unread, while readTable treats the operation as successful and continues parsing from the wrong offset. A malicious or compromised broker can provide an oversized longstr in a table field and desynchronize subsequent AMQP parsing, causing attacker-controlled trailing bytes to be interpreted as later fields or frames and disrupting connection integrity and availability. This issue is fixed in version 1.13.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | golang-github-rabbitmq-amqp091-go | no fix listed | DEBIAN-CVE-2026-77411 |
| Debian:13 | golang-github-rabbitmq-amqp091-go | no fix listed | DEBIAN-CVE-2026-77411 |
| Debian:14 | golang-github-rabbitmq-amqp091-go | 1.14.0-1 | DEBIAN-CVE-2026-77411 |
| Go | github.com/rabbitmq/amqp091-go | 1.13.0 | GO-2026-6496 |
| Go | github.com/rabbitmq/amqp091-go | 1.13.0 | GHSA-c5pq-fr2g-9jpf |
| Ubuntu:24.04:LTS | golang-github-rabbitmq-amqp091-go | no fix listed | UBUNTU-CVE-2026-77411 |
| Ubuntu:26.04:LTS | golang-github-rabbitmq-amqp091-go | no fix listed | UBUNTU-CVE-2026-77411 |
| Ubuntu:26.10 | golang-github-rabbitmq-amqp091-go | no fix listed | UBUNTU-CVE-2026-77411 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | amqp091-go | < 1.13.0 |
Weakness: CWE-754 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-c5pq-fr2g-9jpf x_refsource_CONFIRM
- https://github.com/rabbitmq/amqp091-go/pull/347 x_refsource_MISC
- https://github.com/rabbitmq/amqp091-go/commit/143c1ace5fa7344cee135e5c7d22970f0de68282 x_refsource_MISC
- https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0 x_refsource_MISC