Vulnerability · Published Sep 16, 2026 · Assigned by GitHub_M

CVE-2026-77405RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser

Critical 9.4

In plain English

A critical-severity security flaw in amqp091-go from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.4Critical
Exploit odds (30 days)0.3%top 79.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12golang-github-rabbitmq-amqp091-gono fix listedDEBIAN-CVE-2026-77405
Debian:13golang-github-rabbitmq-amqp091-gono fix listedDEBIAN-CVE-2026-77405
Debian:14golang-github-rabbitmq-amqp091-go1.14.0-1DEBIAN-CVE-2026-77405
Gogithub.com/rabbitmq/amqp091-go1.13.0GO-2026-6492
Gogithub.com/rabbitmq/amqp091-go1.13.0GHSA-33mj-cw25-m34h
Ubuntu:24.04:LTSgolang-github-rabbitmq-amqp091-gono fix listedUBUNTU-CVE-2026-77405
Ubuntu:26.04:LTSgolang-github-rabbitmq-amqp091-gono fix listedUBUNTU-CVE-2026-77405
Ubuntu:26.10golang-github-rabbitmq-amqp091-gono fix listedUBUNTU-CVE-2026-77405

Affected products (as reported)

VendorProductVersions
rabbitmq amqp091-go < 1.13.0

Weakness: CWE-326 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N

References