Vulnerability · Published Sep 23, 2026 · Assigned by apache
CVE-2026-76183Apache Tomcat: Bypass of security constraints for WebSocket endpoints
Critical 9.8
In plain English
A critical-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Authentication Bypass by Alternate Name vulnerability in Apache Tomcat allowed the security constraints for any WebSocket endpoint to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121. The following versions were EOS at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | tomcat10 | no fix listed | DEBIAN-CVE-2026-76183 |
| Debian:13 | tomcat10 | no fix listed | DEBIAN-CVE-2026-76183 |
| Debian:14 | tomcat10 | 10.1.60-1 | DEBIAN-CVE-2026-76183 |
| Debian:13 | tomcat11 | no fix listed | DEBIAN-CVE-2026-76183 |
| Debian:14 | tomcat11 | no fix listed | DEBIAN-CVE-2026-76183 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-76183 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-76183 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-76183 |
| Ubuntu:24.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2026-76183 |
| Ubuntu:26.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2026-76183 |
| Ubuntu:26.10 | tomcat10 | no fix listed | UBUNTU-CVE-2026-76183 |
| Ubuntu:26.04:LTS | tomcat11 | no fix listed | UBUNTU-CVE-2026-76183 |
| Ubuntu:26.10 | tomcat11 | no fix listed | UBUNTU-CVE-2026-76183 |
| Ubuntu:24.04:LTS | tomcat9 | no fix listed | UBUNTU-CVE-2026-76183 |
| Ubuntu:26.04:LTS | tomcat9 | no fix listed | UBUNTU-CVE-2026-76183 |
| Ubuntu:26.10 | tomcat9 | no fix listed | UBUNTU-CVE-2026-76183 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.0-M1 – through 11.0.2510.1.0-M1 – through 10.1.599.0.0.M1 – through 9.0.1218.5.0 – through 8.5.1007.0.43 – through 7.0.109 |
Weakness: CWE-289 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H