Vulnerability · Published Aug 24, 2026 · Assigned by openjs

CVE-2026-76172fast-uri vulnerable to host confusion via percent-encoded scheme normalization

High 7.5

In plain English

A high-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.2%top 85.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri is a URI parser for Node.js. During parsing it runs a legacy decoding pass over the scheme component and never re-escapes the result, and serialization writes the scheme back out verbatim, unlike the host component which is re-escaped. As a result an input whose scheme carries percent-encoded slashes parses as a scheme with no authority, so the parsed host and error are both undefined, yet resolving or normalizing that same input emits a network-path reference whose authority is attacker-chosen and re-parses to that host. An application that allowlists on the parsed host, or treats a reference with no authority as safe to resolve against its base, gets the opposite of what it checked, giving an off-site redirect, server-side request forgery, or address-policy bypass. The legacy decoder also expands non-standard escape forms, widening the issue past upstream filters, and control characters in the scheme can reach the output as raw carriage return and line feed. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which reject a scheme that is not valid after decoding. Users should upgrade to a patched version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10cockpit-image-builder94.4-1.el10_2ALSA-2026:71543
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-76172
Debian:14node-ajv8.20.0~ds+~cs7.1.4-1DEBIAN-CVE-2026-76172
Rocky Linux:10cockpit-image-builder0:94.4-1.el10_2RLSA-2026:71543
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-76172
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-76172
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-76172
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-76172
npmfast-uri2.4.5GHSA-jqff-g426-hqxp
npmfast-uri3.1.6GHSA-jqff-g426-hqxp
npmfast-uri4.1.3GHSA-jqff-g426-hqxp

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 2.3.1 – before 2.4.53.0.0 – before 3.1.64.0.0 – before 4.1.3

Weakness: CWE-177 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References