Vulnerability · Published Aug 24, 2026 · Assigned by openjs

CVE-2026-75931fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references

High 7.5

In plain English

A high-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 65.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri is a URI parser for Node.js. It canonicalizes a host to its ASCII form only when the input carries an explicit scheme, so a scheme-relative reference such as a host preceded by two slashes is returned with its host verbatim and no error set. As a result fast-uri's own entry points disagree with each other: parse, resolve, normalize, and equal can yield different hosts for the same input depending only on whether a scheme is written out, and equal can return opposite verdicts for the same pair of hosts. An application that extracts a host with fast-uri to check it against a policy list and then resolves the same reference can make its decision on one host while the destination is another, enabling host confusion and policy bypass. The affected versions are 2.4.2 up to but not including 2.4.5, 3.1.3 up to but not including 3.1.6, and 4.0.1 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which canonicalize the host consistently across the resolve path. Users should upgrade to a patched version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-75931
Debian:14node-ajv8.20.0~ds+~cs7.1.4-1DEBIAN-CVE-2026-75931
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-75931
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-75931
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-75931
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-75931
npmfast-uri2.4.5GHSA-5jgf-p345-68v8
npmfast-uri3.1.6GHSA-5jgf-p345-68v8
npmfast-uri4.1.3GHSA-5jgf-p345-68v8

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 2.4.2 – before 2.4.53.1.3 – before 3.1.64.0.1 – before 4.1.3

Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References