Vulnerability · Published Aug 18, 2026 · Assigned by VulnCheck
CVE-2026-75913CodeWhale before 0.8.64 Argument Injection via git_show
Critical 9.3
In plain English
A critical-severity security flaw in CodeWhale from Hmbown. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | codewhale | 0.8.64 | GHSA-7j5w-7r7x-9v27 |
| npm | deepseek-tui | 0.8.41 | GHSA-7j5w-7r7x-9v27 |
Affected products (as reported)
Weakness: CWE-73 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:H
References
- GitHub Security Advisory (GHSA-7j5w-7r7x-9v27) vendor-advisory
- Patch Commit patch
- VulnCheck Advisory: CodeWhale before 0.8.64 Argument Injection via git_show third-party-advisory