Vulnerability · Published Aug 18, 2026 · Assigned by VulnCheck
CVE-2026-75857CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact
High 7.0
In plain English
A high-severity privilege mismanagement in CodeWhale from Hmbown. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | codewhale | 0.8.64 | GHSA-g29h-pfmp-qp9r |
| npm | deepseek-tui | 0.8.41 | GHSA-g29h-pfmp-qp9r |
Affected products (as reported)
Weakness: CWE-269 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- GitHub Security Advisory (GHSA-g29h-pfmp-qp9r) vendor-advisory
- Patch Commit patch
- VulnCheck Advisory: CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact third-party-advisory