Vulnerability · Published Aug 18, 2026 · Assigned by VulDB
CVE-2026-75773karakeep-app karakeep Login Endpoint auth.ts authorize excessive authentication
Low 3.7
In plain English
A low-severity security flaw in karakeep from karakeep-app. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 51% of all known vulnerabilities).
Official description
A vulnerability was found in karakeep-app karakeep up to 0.32.0. The affected element is the function authorize of the file apps/web/server/auth.ts of the component Login Endpoint. The manipulation results in improper restriction of excessive authentication attempts. The attack may be performed from remote. This attack is characterized by high complexity. The exploitability is described as difficult. The exploit has been made public and could be used. Upgrading to version 0.33.0 is sufficient to fix this issue. The patch is identified as f7d042971d0d2bcc7119654830cf1eb93eabbf24. It is advisable to upgrade the affected component.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| karakeep-app | karakeep | 0.10.20.30.40.50.60.70.8 |
Weakness: CWE-307, CWE-799 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N/E:P/RL:O/RC:C
References
- VDB-391519 | karakeep-app karakeep Login Endpoint auth.ts authorize excessive authentication vdb-entry, technical-description
- VDB-391519 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- CVE-2026-75773 | CVE Analysis and Report third-party-advisory
- Submit #877731 | karakeep-app karakeep >= 0.3.0, <= 0.32.0 Improper Restriction of Excessive Authentication Attempts third-party-advisory
- https://github.com/karakeep-app/karakeep/issues/2919 exploit, issue-tracking
- https://github.com/karakeep-app/karakeep/commit/f7d042971d0d2bcc7119654830cf1eb93eabbf24 patch
- https://github.com/karakeep-app/karakeep/releases/tag/mcp/v0.33.0 patch
- https://github.com/karakeep-app/karakeep/ product