Vulnerability · Published Oct 22, 2026 · Assigned by GitHub_M

CVE-2026-75507GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule

High 7.5

In plain English

A high-severity uncontrolled resource consumption in graphql-core from graphql-python. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 51.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GraphQL-core is a Python port of the GraphQL.js reference implementation. From 3.0.0 until 3.2.12 and 3.3.0rc1, the OverlappingFieldsCanBeMerged rule in specified_rules repeatedly compares fields that share response names and recursively re-compares flattened inline fragments during the validation phase. The prior named-fragment memoization does not cover this path, so nested repeated inline fragments can drive quadratic and worst-case O(n²·m²) CPU work before any resolver or AST-based depth or complexity control runs. An unauthenticated remote attacker can submit a shallow, highly compressible GraphQL query that pins a worker process and can saturate a multi-worker service. This issue is fixed in versions 3.2.12 and 3.3.0rc1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12graphql-coreno fix listedDEBIAN-CVE-2026-75507
Debian:13graphql-coreno fix listedDEBIAN-CVE-2026-75507
Debian:14graphql-core3.2.12-1DEBIAN-CVE-2026-75507
PyPIgraphql-core3.2.12GHSA-vj8h-fx38-h3vc
PyPIgraphql-core3.3.0rc1GHSA-vj8h-fx38-h3vc
Ubuntu:22.04:LTSgraphql-coreno fix listedUBUNTU-CVE-2026-75507
Ubuntu:24.04:LTSgraphql-coreno fix listedUBUNTU-CVE-2026-75507
Ubuntu:26.04:LTSgraphql-coreno fix listedUBUNTU-CVE-2026-75507
Ubuntu:26.10graphql-coreno fix listedUBUNTU-CVE-2026-75507

Affected products (as reported)

VendorProductVersions
graphql-python graphql-core >= 3.0.0, < 3.2.12>= 3.3.0a1, < 3.3.0rc1

Weakness: CWE-400, CWE-407 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References