Vulnerability · Published Sep 23, 2026 · Assigned by VulnCheck

CVE-2026-75131NetworkManager-l2tp Privilege Escalation via pppd Username Injection

High 7.8

In plain English

A high-severity argument injection in NetworkManager-l2tp from nm-l2tp. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)0.2%top 92.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12network-manager-l2tp1.20.8-1+deb12u1DEBIAN-CVE-2026-75131
Debian:13network-manager-l2tp1.20.20-2+deb13u1DEBIAN-CVE-2026-75131
Debian:14network-manager-l2tp1.52.6-1DEBIAN-CVE-2026-75131
Ubuntu:22.04:LTSnetwork-manager-l2tpno fix listedUBUNTU-CVE-2026-75131
Ubuntu:24.04:LTSnetwork-manager-l2tpno fix listedUBUNTU-CVE-2026-75131
Ubuntu:26.04:LTSnetwork-manager-l2tpno fix listedUBUNTU-CVE-2026-75131
Ubuntu:26.10network-manager-l2tpno fix listedUBUNTU-CVE-2026-75131

Affected products (as reported)

VendorProductVersions
nm-l2tp NetworkManager-l2tp 0 – through 1.52.4

Weakness: CWE-88 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References