Vulnerability · Published Sep 9, 2026 · Assigned by apache
CVE-2026-74761Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Spoofing of RemoveSubscription clientId
High 7.5
In plain English
A high-severity improper input validation in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities).
Official description
Improper input validation in TopicRegion in Apache ActiveMQ, Apache ActiveMQ Broker, and Apache ActiveMQ All on all platforms. An authenticated client can spoof clientId when removing a durable topic subscription. This issue affects Apache ActiveMQ Broker: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ All: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ: before 5.19.11, from 6.0.0 before 6.3.2. Users are recommended to upgrade to version 6.3.2 or 5.19.11 which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:24.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-74761 |
| Ubuntu:26.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-74761 |
| Ubuntu:26.10 | activemq | no fix listed | UBUNTU-CVE-2026-74761 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ActiveMQ Broker | 6.0.0 – before 6.3.20 – before 5.19.11 |
| Apache Software Foundation | Apache ActiveMQ All | 6.0.0 – before 6.3.20 – before 5.19.11 |
| Apache Software Foundation | Apache ActiveMQ | 6.0.0 – before 6.3.20 – before 5.19.11 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N