Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M

CVE-2026-73643js-yaml: Exponential parsing time in the flow collections leads to denial of service

High 7.5

In plain English

A high-severity security flaw in js-yaml from nodeca. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 57.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

js-yaml is a JavaScript YAML parser and dumper. From 5.0.0 until 5.2.2, parsing a small YAML document can take exponential time when an application calls load() or loadAll() on untrusted input. In src/parser/parser.ts, readFlowCollection uses restoreState and calls parseNode a second time when a flow-sequence entry is recognized as a key: value pair. If the key is a nested flow sequence of the same shape, every level is parsed twice, causing O(2^n) work and allowing an input under 200 bytes to keep one CPU busy for minutes, block the Node.js event loop, and stall the process. No anchors, aliases, merges, tags, or nondefault options are required. This issue is fixed in version 5.2.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-73643
Ubuntu:24.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-73643
Ubuntu:26.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-73643
Ubuntu:26.10node-js-yamlno fix listedUBUNTU-CVE-2026-73643
npmjs-yaml5.2.2GHSA-pm4m-ph32-ghv5

Affected products (as reported)

VendorProductVersions
nodeca js-yaml >= 5.0.0, < 5.2.2

Weakness: CWE-407 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References