Vulnerability · Published Aug 13, 2026 · Assigned by VulnCheck
CVE-2026-73626JupyterLab before 4.6.2 Authentication Bypass via PyPIExtensionManager
High 7.5
In plain English
A high-severity improper access control in jupyterlab from jupyterlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | jupyterlab | no fix listed | DEBIAN-CVE-2026-73626 |
| Debian:14 | jupyterlab | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 | DEBIAN-CVE-2026-73626 |
| PyPI | jupyterlab | 4.6.2 | GHSA-whvh-wf3x-g77j |
| PyPI | jupyterlab | 4.5.10 | GHSA-whvh-wf3x-g77j |
| Ubuntu:26.04:LTS | jupyterlab | no fix listed | UBUNTU-CVE-2026-73626 |
| Ubuntu:26.10 | jupyterlab | no fix listed | UBUNTU-CVE-2026-73626 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jupyterlab | jupyterlab | 4.6.0 – before 4.6.1 |
| jupyterlab | jupyterlab | 0 – before 4.5.10 |
Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- GitHub Security Advisory (GHSA-whvh-wf3x-g77j) vendor-advisory
- VulnCheck Advisory: JupyterLab before 4.6.2 Authentication Bypass via PyPIExtensionManager third-party-advisory