Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M

CVE-2026-73557vLLM: Incomplete CVE-2025-62164 remediation can be bypassed by concurrent prompt parts

Medium 6.3

In plain English

A medium-severity race condition in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.2%top 83.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models. From 0.20.2rc0 until 0.26.0, safe_load_prompt_embeds in vllm/renderers/embed_utils.py uses torch.sparse.check_sparse_tensor_invariants, whose process-global save, enable, and restore state can be raced by concurrent prompt_embeds parts submitted to POST /v1/chat/completions through AsyncMultiModalItemTracker.resolve_items, asyncio.gather, and the default executor, allowing an invalid sparse tensor to reach tensor.to_dense despite the CVE-2025-62164 guard when enable_prompt_embeds is enabled. This issue is fixed in version 0.26.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.26.0GHSA-pr7f-p5mw-fc87
PyPIvllm0.26.0PYSEC-2026-3938

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.20.2rc0, < 0.26.0

Weakness: CWE-362 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

References