Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M

CVE-2026-73508Netty: Memory Leak in DNS Record Decoder via Malformed Domain Names

Medium 5.3

In plain English

A medium-severity security flaw in netty from netty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.6%top 49.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Netty is an asynchronous, event-driven network application framework. Prior to 4.1.136.Final and 4.2.16.Final, io.netty.handler.codec.dns.AbstractDnsRecord, io.netty.handler.codec.dns.DefaultDnsRecordDecoder.decodeRecord(), and io.netty.handler.codec.dns.DnsCodecUtil.decompressDomainName() failed to release retained or newly allocated ByteBuf objects when IDN.toASCII() or encodeDomainName() rejected a malformed domain name, allowing unauthenticated remote DNS packets to leak direct memory incrementally until denial of service. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nettyno fix listedDEBIAN-CVE-2026-73508
Debian:13nettyno fix listedDEBIAN-CVE-2026-73508
Debian:14nettyno fix listedDEBIAN-CVE-2026-73508
Mavenio.netty:netty-codec-dns4.2.16.FinalGHSA-mfg7-5gfp-c4w3
Mavenio.netty:netty-codec-dns4.1.136.FinalGHSA-mfg7-5gfp-c4w3
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2026-73508

Affected products (as reported)

VendorProductVersions
netty netty < 4.1.136.Final>= 4.2.0.Final, < 4.2.16.Final

Weakness: CWE-772 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References