Vulnerability · Published Aug 13, 2026 · Assigned by VulnCheck
CVE-2026-73483Flowise before 3.1.3 Sandbox Escape via Puppeteer
Critical 9.4
In plain English
A critical-severity OS command injection in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the vm2/@flowiseai/nodevm JavaScript sandbox. An authenticated user with access to the /api/v1/node-custom-function endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling. In versions 3.0.8–3.1.2 exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default. Fixed in 3.1.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.3 | GHSA-9gvv-qjj3-2p6g |
| npm | flowise-components | 3.1.3 | GHSA-9gvv-qjj3-2p6g |
Affected products (as reported)
Weakness: CWE-78 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- GitHub Security Advisory (GHSA-9gvv-qjj3-2p6g) vendor-advisory
- VulnCheck Advisory: Flowise before 3.1.3 Sandbox Escape via Puppeteer third-party-advisory