Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M

CVE-2026-73420NextAuth.js: Email normalizer validates the address before Unicode normalization, allowing a homoglyph @ bypass

Critical 9.1

In plain English

A critical-severity security flaw in core from @auth. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.1Critical
Exploit odds (30 days)0.7%top 45.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the defaultNormalizer used by the email and magic-link sign-in flow validates an address before applying Unicode normalization. An address can contain a Unicode character such as U+FF20 FULLWIDTH COMMERCIAL AT that is not ASCII at-sign but canonicalizes to an ASCII at-sign under NFKC or NFKD normalization. The address passes the normalizer's single-at-sign check, but a downstream sendVerificationRequest mail library or delivery service that normalizes the address can then see two at-sign separators and deliver the passwordless sign-in link to an attacker-controlled recipient. Applications are affected when the email provider uses the built-in normalizer rather than a custom normalizeIdentifier and the downstream sender applies Unicode normalization. An attacker who knows a victim's email address can request the misrouted magic link and sign in as the victim without victim interaction. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@auth/core0.41.3GHSA-7rqj-j65f-68wh
npmnext-auth4.24.15GHSA-7rqj-j65f-68wh
npmnext-auth5.0.0-beta.32GHSA-7rqj-j65f-68wh

Affected products (as reported)

VendorProductVersions
nextauthjs next-auth < 4.24.15>= 5.0.0-beta.4, < 5.0.0-beta.32
@auth core >= 0.1.0, < 0.41.3

Weakness: CWE-180 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References