Vulnerability · Published Aug 12, 2026 · Assigned by GitHub_M

CVE-2026-73419NextAuth.js: OAuth state, nonce, and PKCE check cookies are not bound to the provider that created them

Medium 6.8

In plain English

A medium-severity insufficient verification of data authenticity in core from @auth. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.8Medium
Exploit odds (30 days)0.2%top 83.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

NextAuth.js provides authentication for Next.js. Prior to@auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, Auth.js stores the OAuth/OIDC anti-CSRF checks state, nonce, and the PKCE verifier in global cookies that are not bound to the provider that created them. On callback, a check value minted during a sign-in started with one provider can satisfy the callback for a different provider because the stored cookie is not verified against the callback provider's identity, including the provider ID, issuer, client ID, or redirect URI. In a multi-provider application that permits account linking while logged in, when one provider's authorization request is observable and a target provider callback can be satisfied without a PKCE verifier, an attacker can lure a victim into starting a legitimate same-origin flow and link the attacker's target-provider account to the victim's Auth.js user. The linked provider grants the attacker persistent sign-in to the victim's account, while cross-site request forgery alone is insufficient. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@auth/core0.41.3GHSA-x445-f3h2-j279
npmnext-auth5.0.0-beta.32GHSA-x445-f3h2-j279
npmnext-auth4.24.15GHSA-x445-f3h2-j279

Affected products (as reported)

VendorProductVersions
nextauthjs next-auth < 4.24.15>= 5.0.0-beta.4, < 5.0.0-beta.32
@auth core < 0.41.3

Weakness: CWE-345, CWE-346, CWE-940 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

References