Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M

CVE-2026-73417JupyterLab: Cross-site scripting (XSS) via crafted settings file (`overrides.json`)

High 8.6

In plain English

A high-severity cross-site scripting in jupyterlab from jupyterlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.7%top 44.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 3.3.0 until 4.5.10 and 4.6.2, JupyterLab allows notebook settings to be shared and applied through an overrides.json file using the Import button in the Settings Editor. In packages/notebook-extension/schema/tracker.json and packages/notebook-extension/src/index.ts, the sideBySideLeftMarginOverride and sideBySideRightMarginOverride settings are not properly validated before being inserted into style content, allowing a crafted settings file to contain instructions that execute as code instead of only changing display preferences. A user can import the malicious file, or an attacker with access to a shared settings location can plant an overrides.json that is applied automatically. The embedded code runs with the affected user's access and can read or modify notebooks and files and run code through the notebook server, including on a connected kernel. This issue is fixed in versions 4.5.10 and 4.6.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13jupyterlabno fix listedDEBIAN-CVE-2026-73417
Debian:14jupyterlab4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4DEBIAN-CVE-2026-73417
PyPIjupyterlab4.5.10, 4.6.2PYSEC-2026-3672
PyPIjupyterlab4.5.10GHSA-pppj-hq3g-57pj
PyPIjupyterlab4.6.2GHSA-pppj-hq3g-57pj
Ubuntu:26.04:LTSjupyterlabno fix listedUBUNTU-CVE-2026-73417
Ubuntu:26.10jupyterlabno fix listedUBUNTU-CVE-2026-73417

Affected products (as reported)

VendorProductVersions
jupyterlab jupyterlab >= 3.3.0, < 4.5.10>= 4.6.0, < 4.6.2

Weakness: CWE-79, CWE-116 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:L

References