Vulnerability · Published Aug 12, 2026 · Assigned by GitHub_M

CVE-2026-73415jupyterlab: Image viewer in JupyterLab allows XSS when opening malicious image in new browser tab

High 7.5

In plain English

A high-severity cross-site scripting in jupyterlab from jupyterlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.5High
Exploit odds (30 days)0.7%top 45.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. Prior to 4.5.10 and 4.6.2, in packages/imageviewer/src/widget.ts, JupyterLab's ImageViewer uses URL.createObjectURL for a specially crafted SVG image and revokes the blob URL too early, allowing the image to retain an executable same-origin context when it is opened through the image viewer and then opened in a new browser tab. The resulting cross-site scripting can be used to execute arbitrary code on the JupyterLab server. This issue is fixed in versions 4.5.10 and 4.6.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13jupyterlabno fix listedDEBIAN-CVE-2026-73415
Debian:14jupyterlab4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4DEBIAN-CVE-2026-73415
PyPIjupyterlab4.6.2GHSA-gx64-gj6p-pc4c
PyPIjupyterlab4.5.10GHSA-gx64-gj6p-pc4c
PyPIjupyterlab4.5.10, 4.6.2PYSEC-2026-3671
Ubuntu:26.04:LTSjupyterlabno fix listedUBUNTU-CVE-2026-73415

Affected products (as reported)

VendorProductVersions
jupyterlab jupyterlab < 4.5.10>= 4.6.0, < 4.6.2

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

References