Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M

CVE-2026-73305Budibase: Privilege escalation via public role assignment API missing app-level authorization

High 8.8

In plain English

A high-severity privilege mismanagement in budibase from Budibase. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities).

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.5%top 55.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Budibase is an open-source low-code platform. Prior to 3.39.24, POST /api/public/v1/roles/assign called validateGlobalRoleUpdate without checking appBuilder.appId or role.appId in packages/server/src/api/controllers/public/globalRoleValidation.ts. An app-scoped builder could scope the request to an app they control and then grant themselves builder access or an arbitrary role in another app, exposing that app data, datasource configuration, and automations. This issue is fixed in version 3.39.24.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@budibase/serverno fix listedGHSA-j9fc-w3mr-x6mv

Affected products (as reported)

VendorProductVersions
Budibase budibase < 3.39.24

Weakness: CWE-269, CWE-862, CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References